Welcome to San Andreas.

...

GTA IV texture bug ( need help )

13 posts in this topic

Posted

the video explains :smile:

http://www.youtube.com/watch?v=X7AZ6bK4q-A

my PC :

CPU : Intel

Share this post


Link to post
Share on other sites

Posted

Remove some of your car mods or lower your settings.

Share this post


Link to post
Share on other sites

Posted

Just curious, did you edit the configuration file "first responder ini" at all?

Share this post


Link to post
Share on other sites

Posted

You either need a better graphics card, or you should follow Harper's advice:

Remove some of your car mods or lower your settings.

Share this post


Link to post
Share on other sites

Posted

I have the same problem. It's not the fault of the graphics card because if I downgrade to a previous version then I have no problems. I have a more powerful system than the OP too.

Share this post


Link to post
Share on other sites

Posted

I have the same problem. It's not the fault of the graphics card because if I downgrade to a previous version then I have no problems. I have a more powerful system than the OP too.

It IS the GPU, you NEED to lower your settings or remove some high poly mods.. the game is causing the card to run out of memory.. Could you post your specs?

Share this post


Link to post
Share on other sites

Posted

I would like to state for the record that on our old computer, we also had the Radeon HD 4600 Series. It could not run GTA IV for whatever reasons. I say it like this because I also never got any textures in-game. It was a while ago, but I do know that I also had modded vehicles, which I now know are what most likely caused my problems. >.< As stated by Harper,

the game is causing the card to run out of memory

Also for the record, I don't want to imply that anyone's graphics card is crappy, it's just the way GTA IV was made.

Share this post


Link to post
Share on other sites

Posted

It's not the fault of the graphics card because if I downgrade to a previous version then I have no problems.

Downgrading to a lower version of GTA IV (I believe that's what you meant) does fix it for some people. The 1.0.7.0 patch causes the game to run like crap on some systems, but high poly car mods only make it worse. I never had any problems with my GTX 560 though, but a lot of people with weaker cards do have texture problems. My old GTX 260 had the same problem. GTA loves to eat up RAM and VRAM. Adding car mods makes this problem exponentially worse. The only real fix is to not use mods, or to get a better system.

Other topics already created with this problem:

http://www.lcpdfr.com/cops/forum/topic/2037-missing-textures-v091/

http://www.lcpdfr.com/cops/forum/topic/2426-missing-textures-roads-buildings-etc/

Share this post


Link to post
Share on other sites

Posted (edited)

It IS the GPU, you NEED to lower your settings or remove some high poly mods.. the game is causing the card to run out of memory.. Could you post your specs?

My specs are:

Intel Core i7 @2.93 GHz

6 GB RAM

ATI Radeon HD 5670 1 GB

I'm using the maximum performance power profile in the Windows control panel and also Process Lasso to get the best performance.

I'm running GTA at a 1280x720 resolution with medium settings overall. The only high poly mods I have are police cars, all other traffic is normal.

Downgrading to a lower version of GTA IV (I believe that's what you meant) does fix it for some people. The 1.0.7.0 patch causes the game to run like crap on some systems, but high poly car mods only make it worse. I never had any problems with my GTX 560 though, but a lot of people with weaker cards do have texture problems. My old GTX 260 had the same problem. GTA loves to eat up RAM and VRAM. Adding car mods makes this problem exponentially worse. The only real fix is to not use mods, or to get a better system.

Other topics already created with this problem:

http://www.lcpdfr.co...-textures-v091/

http://www.lcpdfr.co...-buildings-etc/

I actually meant downgrading LCPD:FR to the previous version is what fixed the problem. Given my specs and the fact that downgrading LCPD:FR fixed the problem, that suggests that the problem lies with 0.95RC1.

Edited by Calvert

Share this post


Link to post
Share on other sites

Posted

With my HD4870 X2 (2GB) I had some similiar problems but only if I had the previous (I think it's 1.25) version of iCEnhancer installed - though I gotta say it was never meant to be played on 1.0.7.0

I think even the new graficcards don't have much more VRAM (most VRAM I saw on a single GPU yet was about 3GB) so why is it running on them but not on my card?

Long story short: you really can't say on which compenents this does depend. IMHO it's a combination of various things no one really could sum up or better sort out...

Edit: Oh but one question... Does this appear when you start the game (from the beginning) or does it appear later on?? Because this is two different "bugs" (I had the last one)

Share this post


Link to post
Share on other sites

Posted

For me, it only started when I arrived at a domestic call about 5 minutes into the game. The domestic call didn't work as there was nothing at the scene (I filed a bug report about it). As soon as I went into the building where the domestic was supposed to be, the texture loading problems started and soon got worse.

Share this post


Link to post
Share on other sites

Posted

For me, it only started when I arrived at a domestic call about 5 minutes into the game. The domestic call didn't work as there was nothing at the scene (I filed a bug report about it). As soon as I went into the building where the domestic was supposed to be, the texture loading problems started and soon got worse.

Did you call for backup? Noose? I noticed glitches occurring when calling for noose backup... if the models do not load properly it will begin to crash.

Share this post


Link to post
Share on other sites

Posted

Did you call for backup? Noose? I noticed glitches occurring when calling for noose backup... if the models do not load properly it will begin to crash.

Go to your ini fie, and set PreloadAllModels = True

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.