Welcome to San Andreas.

...
Sign in to follow this  
Followers 0

Help! How do i turn on the lights and siren?


14 posts in this topic

Posted

Sorry I'm new at this but its looks like a lot of fun how do you turn on the lights and siren on your police car?

Share this post


Link to post
Share on other sites

Posted

If it is a default car, quickly press G to toggle them on or off. If it is an ELS downloaded car, press J or K, for primary and secondary, respectively.

Share this post


Link to post
Share on other sites

Posted

Hope its not a problem that I come and post in this topic, mine was locked as I thought the problem was fixed. Of course I thought everything was fine and when I went to play its not. Still none of the lights worked and it says to press J, K, and L but they do nothing, if I press the <, button that says light mode 1, 2, or 3 active but doesn't actually do anything, I still have the one solid light forward and rear facing. I've gone into ELS and put everything to active. Also none of the cars I have spawn, I either get an error message unable to spawn object, invalid model, or it spawns but is almost a ghost car thats floating in air. So what have I done wrong now? My apologies for asking for help again.

Share this post


Link to post
Share on other sites

Posted (edited)

If you have a backup of vehicles.img, copy it back in to your GTA folder (...\pc\models\cdimages\vehicles.img) and then put your car mods back in one at a time. Start with only one car mod.

Edit: Oh, and make sure ELS.asi and ELS.ini are both in your root GTA folder. (similar to this C:\Program Files (x86)\Steam\steamapps\common\grand theft auto iv\GTAIV)

Edited by Iconography

Share this post


Link to post
Share on other sites

Posted

I've tried and unfortunately nothing is working, should I try uninstalling everything and reinstalling? Or should I try installing everything on my Vista laptop since right now I'm trying this on my Windows 7 laptop. Would that make a difference at all?

Share this post


Link to post
Share on other sites

Posted

break might know,he knows everything!!! ..whatch this speace..

Share this post


Link to post
Share on other sites

Posted

oops space

Share this post


Link to post
Share on other sites

Posted

Can you edit your posts instead of double posting iggor?

And you could try reinstalling GTAIV. Before modding next time, make backups! And I don't think there are any differences when playing on vista or 7.

Share this post


Link to post
Share on other sites

Posted

I've uninstalled and reinstalled everything, and now I'm getting an error and it stops loading.

Share this post


Link to post
Share on other sites

Posted

Are you getting the error without LCPD:FR installed, or after you reinstalled the mod? If you get the error after reinstalling the mod, please run through the checklist, whose link is the first link in my signature. After that you could try running another diagnostic log (link is also found in my sig).

Share this post


Link to post
Share on other sites

Posted

I'm running it after re-installing the mod, and I'm looking through that checklist and I can't find some of those files in the checklist, and I've followed the directions of re-installing with the automatic installer.. Also every time I try running the G17 diagnostic tool it crashes. But it says I have everything needed to run the program. How do I update my version of GTA IV to 1.0.7.0?

Share this post


Link to post
Share on other sites

Posted (edited)

Would Google kill you?

http://games.softped...-IV-Patch.shtml

An unpatched game will cause LCPDFR to crash.

EDIT: Oh, make sure to run the diagnostic log and the First Response as an admin.

Edited by Iconography

Share this post


Link to post
Share on other sites

Posted

Now for initiating a traffic stop is is SHIFT?

Share this post


Link to post
Share on other sites

Posted

Yes, shift.

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0